My Turbo Optima never ran

The place for all things Kyosho.

Moderator: GoMachV

Post Reply
User avatar
cpebach
Regular Member
Posts: 37
Joined: Fri Jul 31, 2009 8:39 am
Location: South Korea

My Turbo Optima never ran

Post by cpebach » Sat Jan 16, 2010 7:41 am

Below photos are my Turbo Optima never ran status.
Optima body uploaded last topic and this Turbo Optima were painted by my friend, NK graphics in Korea.

I matched the radios and battery as vintage parts and ready to run staus.
Attachments
IMG_0742.JPG
IMG_0741.JPG
IMG_0740.JPG
IMG_0739.JPG
IMG_0738.JPG
IMG_0737.JPG
IMG_0735.JPG
IMG_0734.JPG
IMG_0733.JPG
IMG_0728.JPG
Painted by NK graphics
IMG_0735.JPG
IMG_0734.JPG

treehugger
Approved Member
Posts: 2118
Joined: Wed Dec 09, 2009 3:10 am
Location: seattle washington

Re: My Turbo Optima never ran

Post by treehugger » Sat Jan 16, 2010 9:31 am

NICE !!!!!!!!!

User avatar
RedScampi
Approved Member
Posts: 2750
Joined: Sat Aug 30, 2008 11:35 am
Location: Bonney Lake, WA

Re: My Turbo Optima never ran

Post by RedScampi » Sat Jan 16, 2010 1:13 pm

Outstanding looking car. Is the pinstrping done with paint or tape?
Gary

User avatar
cpebach
Regular Member
Posts: 37
Joined: Fri Jul 31, 2009 8:39 am
Location: South Korea

Re: My Turbo Optima never ran

Post by cpebach » Sat Jan 16, 2010 2:20 pm

RedScampi wrote:Outstanding looking car. Is the pinstrping done with paint or tape?
Hi black pinstriping is tape. Maybe black pinstriping with paint clearly is very hard.

rcjunkie3000
Regular Member
Posts: 11
Joined: Sat Jun 13, 2009 2:01 am
Location: Northern California USA

Re: My Turbo Optima never ran

Post by rcjunkie3000 » Wed Jan 20, 2010 3:03 am

Very nice box art scheme. I was going to ask the same question about the black pin stripe.

Is the driver painted from the inside or the outside? I haven't painted my driver yet but I will paint it on the outside because I would think the colors would be subdued because of the tinted plastic.

Heffay
Approved Member
Posts: 152
Joined: Sun Dec 20, 2009 4:24 pm
Location: Colorado

Re: My Turbo Optima never ran

Post by Heffay » Wed Jan 20, 2010 3:07 am

Looks like its never been run!
Oh, wait... :mrgreen:

Excellent specimen. Hang on to it.
JRX2 in the late 80s... have since come to my senses with the RC10T, yes of course it's vintage! Wife is always destroying her Tamiaya LunchBox to call me her personal mechanic a few more times. Enjoying the fresh build of an RJ Speed Digger.

mugenbulldog
Regular Member
Posts: 74
Joined: Thu Dec 03, 2009 3:03 am
Location: Denver, CO, USA

Re: My Turbo Optima never ran

Post by mugenbulldog » Thu Jan 21, 2010 3:29 am

Thanks for posting the pictures of the Turbo Optima and Optima. Paint is definitely top-notch. I also really like the drivers with the simple scheme contrasting the smoked polycarbonate. You need an authentic driver to pull that off, the reproductions that Marwan makes are clear polycarbonate.

briang
Regular Member
Posts: 51
Joined: Mon May 25, 2009 3:32 am

Re: My Turbo Optima never ran

Post by briang » Sat Jan 23, 2010 3:00 am

Sweet!

treehugger
Approved Member
Posts: 2118
Joined: Wed Dec 09, 2009 3:10 am
Location: seattle washington

Re: My Turbo Optima never ran

Post by treehugger » Sat Jan 23, 2010 3:46 am

i have been restoring a turbo optima and after i fitted the resistors i cant fit the body do i have to cut out the body to make it fit it dosen,t show that in the book of instructions
Attachments
P1010022.JPG

Ayk Viper
Regular Member
Posts: 69
Joined: Thu Feb 07, 2008 3:24 am

Re: My Turbo Optima never ran

Post by Ayk Viper » Sat Jan 23, 2010 8:25 am

Treehugger - small picture in manual:
P1060276.JPG
The car body is cutout to accomodate also:
P1060279.JPG

treehugger
Approved Member
Posts: 2118
Joined: Wed Dec 09, 2009 3:10 am
Location: seattle washington

Re: My Turbo Optima never ran

Post by treehugger » Sat Jan 23, 2010 9:01 am

i have the turbo optima instuctions the optima ones must place the resistors in a different local the turbo shows them on the motor guard

Ayk Viper
Regular Member
Posts: 69
Joined: Thu Feb 07, 2008 3:24 am

Re: My Turbo Optima never ran

Post by Ayk Viper » Sat Jan 23, 2010 9:05 am

Yes, the standard Optima resistors are placed on the circular cutout of the left rear chassis plate...but caught too much dirt so they moved it (without changing the chassis).

treehugger
Approved Member
Posts: 2118
Joined: Wed Dec 09, 2009 3:10 am
Location: seattle washington

Re: My Turbo Optima never ran

Post by treehugger » Sat Jan 23, 2010 5:30 pm

:oops: thanks ayk i guess my inability to read all the instructions (or look at the Japanese symbols ) saved me from cutting my body

User avatar
cpebach
Regular Member
Posts: 37
Joined: Fri Jul 31, 2009 8:39 am
Location: South Korea

Re: My Turbo Optima never ran

Post by cpebach » Wed Jan 27, 2010 12:38 am

rcjunkie3000 wrote:Very nice box art scheme. I was going to ask the same question about the black pin stripe.

Is the driver painted from the inside or the outside? I haven't painted my driver yet but I will paint it on the outside because I would think the colors would be subdued because of the tinted plastic.

User avatar
cpebach
Regular Member
Posts: 37
Joined: Fri Jul 31, 2009 8:39 am
Location: South Korea

Re: My Turbo Optima never ran

Post by cpebach » Wed Jan 27, 2010 12:45 am

mugenbulldog wrote:Thanks for posting the pictures of the Turbo Optima and Optima. Paint is definitely top-notch. I also really like the drivers with the simple scheme contrasting the smoked polycarbonate. You need an authentic driver to pull that off, the reproductions that Marwan makes are clear polycarbonate.
Hi!
I also love Marwan's great reproduction bodies. the body is Marwan's but driver is original.

Post Reply

Return to “Kyosho Forum”

Users browsing this forum: No registered users and 4 guests