yz10 tub/brushless

The place for all things Yokomo.

Moderators: scr8p, klavy69

corkyjohnson75
Approved Member
Posts: 47
Joined: Sun Nov 16, 2008 10:00 pm

yz10 tub/brushless

Post by corkyjohnson75 »

hi guys . i was gona sell this buggy but i carnt let it go so if you were interested sorry. is there any one using brushless and lipo in one of these im thinking about it but not sure it would take it . ive put new belts in and was thinking of a 10.5 motor . also need set up and mod tips thanks.
Attachments
Photo 3.jpg
Photo 2.jpg
Photo 1.jpg

User avatar
PBR Allstar
Approved Member
Posts: 805
Joined: Tue May 01, 2007 2:30 am
Location: Sonoma, Ca
Has thanked: 1 time
Been thanked: 3 times

Re: yz10 tub/brushless

Post by PBR Allstar »

I think it would take a 10.5 without much issue. a 10.5 is only has a little more nuts than a 19T and BITD people ran sub 9T motors in the cars. I would look for a t.c.s. system for the car, it's not so much the power of the motor that kills parts, its the shock loads (i.e. full throttle landings and what not)

User avatar
jooles
Regular Member
Posts: 16
Joined: Thu Nov 05, 2009 11:45 pm
Location: Kardjali, Bulgaria / Nantes, France

Re: yz10 tub/brushless

Post by jooles »

Hi,

Honestly, I wouldn't run this one... This would be a shame to damage this tub...

Julien

User avatar
kenooze
Approved Member
Posts: 566
Joined: Fri Jan 19, 2007 4:02 pm
Location: Paris
Been thanked: 3 times

Re: yz10 tub/brushless

Post by kenooze »

What's this car, the motor and the servo looks to be at the opposite side as usual.

Strenge !

Jay Dub
Approved Member
Posts: 1136
Joined: Tue Jul 29, 2008 5:04 am
Location: San Jose, Ca.
Been thanked: 1 time

Re: yz10 tub/brushless

Post by Jay Dub »

This YZ-10 was built for tracks in Australia and South America. I believe they were called "Reverse Spec'd". Everything on the other side of the equator needs to be on the opposite side of the car in order to function properly. Or it could be that the pics are backwards. 8) -Jeff

corkyjohnson75
Approved Member
Posts: 47
Joined: Sun Nov 16, 2008 10:00 pm

Re: yz10 tub/brushless

Post by corkyjohnson75 »

THE PICS ARE BACKWARDS.

Jay Dub
Approved Member
Posts: 1136
Joined: Tue Jul 29, 2008 5:04 am
Location: San Jose, Ca.
Been thanked: 1 time

Re: yz10 tub/brushless

Post by Jay Dub »

IT'S CALLED A JOKE.

User avatar
GJW
Approved Member
Posts: 2325
Joined: Mon Oct 15, 2007 11:22 pm
Location: AUSTRALIA!!
Been thanked: 1 time

Re: yz10 tub/brushless

Post by GJW »

:lol: :lol: :lol:

  • Similar Topics
    Replies
    Views
    Last post
  • YZ10 '94 Carbon Tub *UPDATE 10/24*
    by fakiee » » in Yokomo Forum
    16 Replies
    1497 Views
    Last post by slotcarrod
  • gold tub and brushless
    by bigmd » » in RC10 Buggy Forum
    5 Replies
    635 Views
    Last post by civilguy
  • Brushless setup for first gold tub
    by Robin » » in Modern Electronics
    3 Replies
    613 Views
    Last post by Robin
  • weight difference between 10T tub and t2 tub
    by cautrell05 » » in RC10 Truck Forum
    1 Replies
    546 Views
    Last post by justinspeed79
  • CML YZ10 lay down front towers (early YZ10).... ???
    by buttmonkey1969 » » in Yokomo Forum
    6 Replies
    1235 Views
    Last post by buttmonkey1969
  • Ronbo's YZ870C YZ10 Masami 89 and/or my YZ10 schemes...
    by Ronbo » » in Yokomo Forum
    18 Replies
    3624 Views
    Last post by Ronbo
  • Manual for YZ10 Pavidis and YZ10 97
    by FC5687 » » in Yokomo Forum
    1 Replies
    101 Views
    Last post by Toaster
  • Graphite vs tub
    by foots » » in RC10 Buggy Forum
    5 Replies
    731 Views
    Last post by Charlie don't surf

Return to “Yokomo Forum”

Who is online

Users browsing this forum: No User AvatarCommonCrawl [Bot] and 0 guests