First Yokomo!

The place for all things Yokomo.

Moderators: scr8p, klavy69

SinCityMedic
Regular Member
Posts: 25
Joined: Tue Jul 10, 2012 5:38 am
Location: Lost Wages, NV

First Yokomo!

Post by SinCityMedic »

Been collecting AE stuff for awhile and figured Yoko would be a natural progression. Needless to say, I am super exited to get this baby cleaned up. I'm pretty sure this is a 94' YZ10. A few questions. I have seen people list similar buggies as "super" dogfighter. Is that a manufacturer designation? Can someone ID the turnbuckles plz? And any other non OEM parts? Front bumper? I just noticed the battery hold downs are on the bench. They are the white fiberglass type. Thanks!
Attachments
Yoko5.JPG
Yoko4.JPG
Yoko3.JPG
Yoko2.JPG
Yoko1.JPG

Mikeyboy
Approved Member
Posts: 229
Joined: Mon Sep 01, 2008 2:27 am
Location: Auburn, CA
Been thanked: 1 time

Re: First Yokomo!

Post by Mikeyboy »

Very nice! I' ve always wanted one of those. Where did you find it?

Charlie don't surf
Approved Member
Posts: 8921
Joined: Tue Apr 08, 2008 6:44 pm
Location: USA
Been thanked: 7 times

Re: First Yokomo!

Post by Charlie don't surf »

Clean that bumper up well, they're hard to locate. Your right- its a 94' YZ10 all stock, but incorrect rear tires and tecnacraft turnbuckles- everything else I see off hand from the wing, mounts, and buttons are correct 8)

SinCityMedic
Regular Member
Posts: 25
Joined: Tue Jul 10, 2012 5:38 am
Location: Lost Wages, NV

Re: First Yokomo!

Post by SinCityMedic »

Mikeyboy wrote:Very nice! I' ve always wanted one of those. Where did you find it?
I run "junk rc" wanted ads on Craigslist. Guy emailed me. I had to talk him off his delusion though. He was convinced it was from the 70's :shock:

SinCityMedic
Regular Member
Posts: 25
Joined: Tue Jul 10, 2012 5:38 am
Location: Lost Wages, NV

Re: First Yokomo!

Post by SinCityMedic »

Charlie don't surf wrote:Clean that bumper up well, they're hard to locate. Your right- its a 94' YZ10 all stock, but incorrect rear tires and tecnacraft turnbuckles- everything else I see off hand from the wing, mounts, and buttons are correct 8)
Sweet! I'm really stoked on such a clean/stock find! Especially here in vegas. It's such a transient town.

Yeah the tires are hot laps and rotted out. I acetone my modern tires off all the time, any experience with these older plastics? Don't want to melt the rims lol.


Recommend a cleaner? Plain ol soap and water?

Thanks for all the help!

aip47-2008
Approved Member
Posts: 1186
Joined: Mon Feb 09, 2009 2:20 am
Location: Spokane, WA
Has thanked: 126 times
Been thanked: 23 times

Re: First Yokomo!

Post by aip47-2008 »

SinCityMedic wrote:
Charlie don't surf wrote:Clean that bumper up well, they're hard to locate. Your right- its a 94' YZ10 all stock, but incorrect rear tires and tecnacraft turnbuckles- everything else I see off hand from the wing, mounts, and buttons are correct 8)
Sweet! I'm really stoked on such a clean/stock find! Especially here in vegas. It's such a transient town.

Yeah the tires are hot laps and rotted out. I acetone my modern tires off all the time, any experience with these older plastics? Don't want to melt the rims lol.


Recommend a cleaner? Plain ol soap and water?

Thanks for all the help!

Acetone will work fine with those wheels and Simple Green works wonders on the other parts!

User avatar
ralphee
Approved Member
Posts: 473
Joined: Sun Apr 22, 2012 7:45 am
Location: England

Re: First Yokomo!

Post by ralphee »

Good find, looks like itll clean up well, and yes, to second Reggie's comment, scrub that bumper, rare as hens teeth, damn, i love these cars lol.

lee

SinCityMedic
Regular Member
Posts: 25
Joined: Tue Jul 10, 2012 5:38 am
Location: Lost Wages, NV

Re: First Yokomo!

Post by SinCityMedic »

What are the correct tires front/rear on this model?

mm.yokomo
Regular Member
Posts: 26
Joined: Tue Nov 04, 2008 11:08 pm
Location: Puerto Rico

Re: First Yokomo!

Post by mm.yokomo »

SinCityMedic wrote:What are the correct tires front/rear on this model?
Hi! I'm also looking for tires/wheels for this car. I have one and would like to get the time correct ones. I have a new set of black 2.15" wheels, are these ok?

Charlie don't surf
Approved Member
Posts: 8921
Joined: Tue Apr 08, 2008 6:44 pm
Location: USA
Been thanked: 7 times

Re: First Yokomo!

Post by Charlie don't surf »

mm.yokomo wrote:
SinCityMedic wrote:What are the correct tires front/rear on this model?
Hi! I'm also looking for tires/wheels for this car. I have one and would like to get the time correct ones. I have a new set of black 2.15" wheels, are these ok?
The 94' should have the 2.2 reinforced rib wheels (to be correct) the 2.15's were early works 91'

mm.yokomo
Regular Member
Posts: 26
Joined: Tue Nov 04, 2008 11:08 pm
Location: Puerto Rico

Re: First Yokomo!

Post by mm.yokomo »

Charlie, thanks for the quick reply! Will keep looking for those 2.2 rib wheels. Those came in white or black, right?

Charlie don't surf
Approved Member
Posts: 8921
Joined: Tue Apr 08, 2008 6:44 pm
Location: USA
Been thanked: 7 times

Re: First Yokomo!

Post by Charlie don't surf »

Yep, both-

User avatar
DerbyDan
Approved Member
Posts: 1836
Joined: Tue Sep 08, 2009 12:04 pm
Location: Northampton UK
Has thanked: 2 times
Been thanked: 17 times

Re: First Yokomo!

Post by DerbyDan »

Well, you learn something new every day.... I didn't realise the ribbed wheels can in both 2.15 & 2.2" :D

Looks like a great find SinCityMedic.... a little clean up & it will be looking first class! I'm also a big fan of the 94 model, I never had the oportunity to race one when they were new (too expensive for me) - but I understand that many racers prefered the earlier 'Works' models.

As for what the kit tyres should be - I presume that the tyres shown on RC10Talk member YZ-10's lovely new-built example are correct? I presume these are TR31s? (Reg??)
Image

Charlie don't surf
Approved Member
Posts: 8921
Joined: Tue Apr 08, 2008 6:44 pm
Location: USA
Been thanked: 7 times

Re: First Yokomo!

Post by Charlie don't surf »

Those are TR31's- and period correct, but not kit correct- and the ribbed were 2.2 only

User avatar
a01butal
Approved Member
Posts: 2397
Joined: Sat Jan 12, 2008 2:15 pm
Location: Shorewood, IL
Has thanked: 33 times
Been thanked: 37 times

Re: First Yokomo!

Post by a01butal »

Charlie don't surf wrote:Those are TR31's- and period correct, but not kit correct- and the ribbed were 2.2 only
What's kit correct?
___________________________________________________________


This is all very interesting!

  • Similar Topics
    Replies
    Views
    Last post
  • My Yokomo story.....Yokomo no 1..870c
    by flustorm99 » » in Yokomo Forum
    7 Replies
    1417 Views
    Last post by flustorm99
  • My Yokomo story...Yokomo no 2 91 works...or is it?
    by flustorm99 » » in Yokomo Forum
    18 Replies
    2384 Views
    Last post by stickboy007
  • Yokomo Worlds edition with "Yokomo Rough Track Kit"
    by Scott S. » » in Yokomo Forum
    22 Replies
    4004 Views
    Last post by pUs
  • Yokomo... But which one is this?
    by iiokurud » » in Yokomo Forum
    9 Replies
    1853 Views
    Last post by DennisM
  • from what yokomo
    by GJW » » in Yokomo Forum
    4 Replies
    963 Views
    Last post by GJW
  • What yokomo is this?
    by ericsp2 » » in Yokomo Forum
    10 Replies
    1205 Views
    Last post by ericsp2
  • yokomo help
    by ericsp2 » » in Yokomo Forum
    18 Replies
    2480 Views
    Last post by isobarik
  • Yokomo MX-4
    by Konich » » in Yokomo Forum
    14 Replies
    1935 Views
    Last post by phoenix

Return to “Yokomo Forum”

Who is online

Users browsing this forum: No User AvatarCommonCrawl [Bot] and 1 guest